#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b0+\B"
Local $sString = "192.168.1.09" & @CRLF & _
"192.168.01.9" & @CRLF & _
"192.168.001.009" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.168.0.256" & @CRLF & _
"192.168.00.256"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")