const regex = new RegExp('\\b0+\\B', 'gm')
const str = `192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}