import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0+\\B";
final String string = "192.168.1.09\n"
+ "192.168.01.9\n"
+ "192.168.001.009\n"
+ "192.168.0.1\n"
+ "192.168.0.256\n"
+ "192.168.00.256";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}