using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0+\B";
string input = @"192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}