$re = '/\b0+\B/m';
$str = '192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);