package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0+\B`)
var str = `192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}