re = /\b0+\B/m
str = '192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end