// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b0+\B").unwrap();
let string = "192.168.1.09
192.168.01.9
192.168.001.009
192.168.0.1
192.168.0.256
192.168.00.256";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}