#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^GO\b"
Local $sString = "SET ANSI_NULLS ON" & @CRLF & _
"GO " & @CRLF & _
"SET QUOTED_IDENTIFIER ON" & @CRLF & _
"GO " & @CRLF & _
"--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO " & @CRLF & _
"--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo." & @CRLF & _
"GO " & @CRLF & _
"GOIAS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")