$re = '/^GO\b/m';
$str = 'SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO
--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.
GO
GOIAS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);