const regex = /^GO\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GO\\b', 'gm')
const str = `SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO
--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.
GO
GOIAS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}