import re
regex = re.compile(r"^GO\b", flags=re.MULTILINE)
test_str = ("SET ANSI_NULLS ON\n"
"GO \n"
"SET QUOTED_IDENTIFIER ON\n"
"GO \n"
"--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO \n"
"--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.\n"
"GO \n"
"GOIAS")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")