// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^GO\b").unwrap();
let string = "SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO
--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.
GO
GOIAS";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}