#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+"
Local $sString = "β€οΈπππππΎππβ€οΈ" & @CRLF & _
"0οΈβ£" & @CRLF & _
"1οΈβ£" & @CRLF & _
"2οΈβ£" & @CRLF & _
"3οΈβ£" & @CRLF & _
"4οΈβ£" & @CRLF & _
"5οΈβ£" & @CRLF & _
"6οΈβ£" & @CRLF & _
"7οΈβ£" & @CRLF & _
"8οΈβ£" & @CRLF & _
"9οΈβ£" & @CRLF & _
"012345" & @CRLF & _
"β€οΈπππππΎππβ€οΈ" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")