import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![0-9]\\x{FE0F}\\x{20E3}|\\x{2139})[\\pL\\pN]+";
final String string = "β€οΈπππππΎππβ€οΈ\n"
+ "0οΈβ£\n"
+ "1οΈβ£\n"
+ "2οΈβ£\n"
+ "3οΈβ£\n"
+ "4οΈβ£\n"
+ "5οΈβ£\n"
+ "6οΈβ£\n"
+ "7οΈβ£\n"
+ "8οΈβ£\n"
+ "9οΈβ£\n"
+ "012345\n"
+ "β€οΈπππππΎππβ€οΈ\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}