const regex = /(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![0-9]\\x{FE0F}\\x{20E3}|\\x{2139})[\\pL\\pN]+', 'gu')
const str = `β€οΈπππππΎππβ€οΈ
0οΈβ£
1οΈβ£
2οΈβ£
3οΈβ£
4οΈβ£
5οΈβ£
6οΈβ£
7οΈβ£
8οΈβ£
9οΈβ£
012345
β€οΈπππππΎππβ€οΈ
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}