using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+";
string input = @"β€οΈπππππΎππβ€οΈ
0οΈβ£
1οΈβ£
2 οΈβ£
3οΈβ£
4οΈβ£
5οΈβ£
6οΈβ£
7οΈβ£
8οΈβ£
9οΈβ£
012345
β€οΈπππππΎππβ€οΈ
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}