import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
β€οΈπππππΎππβ€οΈ
0οΈβ£
1οΈβ£
2οΈβ£
3οΈβ£
4οΈβ£
5οΈβ£
6οΈβ£
7οΈβ£
8οΈβ£
9οΈβ£
012345
β€οΈπππππΎππβ€οΈ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)