re = /(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+/
str = 'β€οΈπππππΎππβ€οΈ
0οΈβ£
1οΈβ£
2οΈβ£
3οΈβ£
4οΈβ£
5οΈβ£
6οΈβ£
7οΈβ£
8οΈβ£
9οΈβ£
012345
β€οΈπππππΎππβ€οΈ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end