# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+"
test_str = ("β€οΈπππππΎππβ€οΈ\n"
"0οΈβ£\n"
"1οΈβ£\n"
"2οΈβ£\n"
"3οΈβ£\n"
"4οΈβ£\n"
"5οΈβ£\n"
"6οΈβ£\n"
"7οΈβ£\n"
"8οΈβ£\n"
"9οΈβ£\n"
"012345\n"
"β€οΈπππππΎππβ€οΈ\n\n")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.