use strict;
my $str = 'β€οΈπππππΎππβ€οΈ
0οΈβ£
1οΈβ£
2οΈβ£
3οΈβ£
4οΈβ£
5οΈβ£
6οΈβ£
7οΈβ£
8οΈβ£
9οΈβ£
012345
β€οΈπππππΎππβ€οΈ
';
my $regex = qr/(?![0-9]\x{FE0F}\x{20E3}|\x{2139})[\pL\pN]+/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}