#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^RUN (.*?(?<! \\)$)"
Local $sString = "FROM builder AS publisher" & @CRLF & _
"ARG ARTIFACTORY_URL" & @CRLF & _
"ARG VERSION" & @CRLF & _
"# Publish Linux binary" & @CRLF & _
"RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \" & @CRLF & _
" && curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz" & @CRLF & _
"WORKDIR /src" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")