using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^RUN (.*?(?<! \\)$)";
string input = @"FROM builder AS publisher
ARG ARTIFACTORY_URL
ARG VERSION
# Publish Linux binary
RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \
&& curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz
WORKDIR /src
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}