import re
regex = re.compile(r"^RUN (.*?(?<! \\)$)", flags=re.MULTILINE | re.DOTALL)
test_str = ("FROM builder AS publisher\n"
"ARG ARTIFACTORY_URL\n"
"ARG VERSION\n"
"# Publish Linux binary\n"
"RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \\\n"
" && curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz\n"
"WORKDIR /src\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")