import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^RUN (.*?(?<! \\\\)$)";
final String string = "FROM builder AS publisher\n"
+ "ARG ARTIFACTORY_URL\n"
+ "ARG VERSION\n"
+ "# Publish Linux binary\n"
+ "RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \\\n"
+ " && curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz\n"
+ "WORKDIR /src\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}