const regex = /^RUN (.*?(?<! \\)$)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^RUN (.*?(?<! \\\\)$)', 'gms')
const str = `FROM builder AS publisher
ARG ARTIFACTORY_URL
ARG VERSION
# Publish Linux binary
RUN tar -zcvf bsfsemver-\${VERSION}.tgz ./bsfsemver \\
&& curl -u \${ARTIFACTORY_USR}:\${ARTIFACTORY_PSW} -T bsfsemver-\${VERSION}.tgz https://\${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-\${VERSION}.tgz
WORKDIR /src
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}