re = /^RUN (.*?(?<! \\)$)/m
str = 'FROM builder AS publisher
ARG ARTIFACTORY_URL
ARG VERSION
# Publish Linux binary
RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \\
&& curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz
WORKDIR /src
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end