use strict;
my $str = 'FROM builder AS publisher
ARG ARTIFACTORY_URL
ARG VERSION
# Publish Linux binary
RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \\
&& curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz
WORKDIR /src
';
my $regex = qr/^RUN (.*?(?<! \\)$)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}