$re = '/^RUN (.*?(?<! \\\\)$)/ms';
$str = 'FROM builder AS publisher
ARG ARTIFACTORY_URL
ARG VERSION
# Publish Linux binary
RUN tar -zcvf bsfsemver-${VERSION}.tgz ./bsfsemver \\
&& curl -u ${ARTIFACTORY_USR}:${ARTIFACTORY_PSW} -T bsfsemver-${VERSION}.tgz https://${ARTIFACTORY_URL}/artifactory/bsf-generic/bsf/bsfsemver/bsfsemver-${VERSION}.tgz
WORKDIR /src
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);