using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^,+|,+$";
string substitution = @"";
string input = @",,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}