re = /^,+|,+$/m
str = ',,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result