import re
regex = re.compile(r"^,+|,+$", flags=re.MULTILINE)
test_str = (",,,,,,,12345\n"
"12345,1345,1354\n"
"123,,,,,,\n"
"12345,\n"
",12354")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)