use strict;
my $str = ',,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354';
my $regex = qr/^,+|,+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";