$re = '/^,+|,+$/m';
$str = ',,,,,,,12345
12345,1345,1354
123,,,,,,
12345,
,12354';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;