#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:/\*(?:.|\n)*?\*/)|(?://.*))"
Local $sString = "/* deliberately different */" & @CRLF & _
"// test line 1" & @CRLF & _
"// test line 2" & @CRLF & _
"var test_http = "http://test.com";" & @CRLF & _
"" & @CRLF & _
"this will not match //even though its a comment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")