// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:/\*(?:.|\n)*?\*/)|(?://.*))").unwrap();
let string = "/* deliberately different */
// test line 1
// test line 2
var test_http = \"http://test.com\";
this will not match //even though its a comment";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}