re = /^(?:(?:\/\*(?:.|\n)*?\*\/)|(?:\/\/.*))/m
str = '/* deliberately different */
// test line 1
// test line 2
var test_http = "http://test.com";
this will not match //even though its a comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end