const regex = new RegExp('^(?:(?:/\\*(?:.|\\n)*?\\*/)|(?://.*))', 'gm')
const str = `/* deliberately different */
// test line 1
// test line 2
var test_http = "http://test.com";
this will not match //even though its a comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}