import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:/\\*(?:.|\\n)*?\\*/)|(?://.*))";
final String string = "/* deliberately different */\n"
+ "// test line 1\n"
+ "// test line 2\n"
+ "var test_http = \"http://test.com\";\n\n"
+ "this will not match //even though its a comment";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}