import re
regex = re.compile(r"^(?:(?:/\*(?:.|\n)*?\*/)|(?://.*))", flags=re.MULTILINE)
test_str = ("/* deliberately different */\n"
"// test line 1\n"
"// test line 2\n"
"var test_http = \"http://test.com\";\n\n"
"this will not match //even though its a comment")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")