using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:/\*(?:.|\n)*?\*/)|(?://.*))";
string input = @"/* deliberately different */
// test line 1
// test line 2
var test_http = ""http://test.com"";
this will not match //even though its a comment";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}