$re = '/^(?:(?:/\*(?:.|\n)*?\*/)|(?://.*))/m';
$str = '/* deliberately different */
// test line 1
// test line 2
var test_http = "http://test.com";
this will not match //even though its a comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);