# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<input name="__RequestVerificationToken" type="hidden" value="([A-Za-z0-9+=\\/\-\_]+)">//;t' <<< "<input name=\"__RequestVerificationToken\" type=\"hidden\" value=\"fdsafs\">"