package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input name="__RequestVerificationToken" type="hidden" value="([A-Za-z0-9+=\/\-\_]+)">`)
var str = []byte(`<input name="__RequestVerificationToken" type="hidden" value="fdsafs">`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}