use strict;
my $str = '<input name="__RequestVerificationToken" type="hidden" value="fdsafs">';
my $regex = qr/<input name="__RequestVerificationToken" type="hidden" value="([A-Za-z0-9+=\/\-\_]+)">/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";