re = /<input name="__RequestVerificationToken" type="hidden" value="([A-Za-z0-9+=\/\-\_]+)">/
str = '<input name="__RequestVerificationToken" type="hidden" value="fdsafs">'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result