import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input name=\"__RequestVerificationToken\" type=\"hidden\" value=\"([A-Za-z0-9+=\\/\\-\\_]+)\">";
final String string = "<input name=\"__RequestVerificationToken\" type=\"hidden\" value=\"fdsafs\">";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}