#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b"
Local $sString = "2359" & @CRLF & _
"0000" & @CRLF & _
"1330" & @CRLF & _
"" & @CRLF & _
"2400" & @CRLF & _
"2360" & @CRLF & _
"2500" & @CRLF & _
"" & @CRLF & _
"1322" & @CRLF & _
"0001" & @CRLF & _
"2500" & @CRLF & _
"2400" & @CRLF & _
"2359" & @CRLF & _
"0123" & @CRLF & _
"4321" & @CRLF & _
"2059"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")