use strict;
my $str = '2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059';
my $regex = qr/\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}