package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b`)
var str = `2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}